Supported Browsers

 

Note: 128-Bit Encryption is required for all browsers.

 

Supported Browsers for using MCCU's e-branch:

 

Windows

  • Internet Explorer 6.0 with Service Pack 2 or later versions
  • Firefox 3.5
  • Netscape 7.2

 

MAC

  • Firefox 3.5
  • Netscape 9.0

 

Attention: e-branch does NOT operate with the following browsers:

  • AOL
    (if you subscribe to AOL, you may first log in to your AOL account to initiate your internet connectivity, then minimize your AOL screen and click on Internet Explorer or Netscape to use e-branch)
  • Web TV
  • MAC running Internet Explorer
  • MAC running Safari

 

Download Firefox

Download Netscape

Platinum Membership Information
 
Refer a Friend
 
Matadors Money Matters Blog